Issue with 4KEX40-eARC suddenly dropping Audio


I’m using the 4KEX40-eARC to take audio from my Samsung TV via eARC to a Marantz 6012 receiver.

In normal operation, everything works GREAT. No dropouts, various surround sound formats work, etc… However, at seemingly random times it simply stops sending audio back to the Marantz until I cycle the extender.

Once the extender is rebooted (by unplugging and replugging in the RJ45 on the TV-end, which gets its power from the extender on the Marantz end), everything again works perfectly, but I’ve found no way (changing audio formats, TV settings, cycling other devices, swapping other cables, etc…) to get things working again without power cycling the 4KEX40-eARC.

The audio stoppage seems random, but often seems to coincide with switching content, so it may be related to changes in the format of the audio being passed back – but I’m unable to trigger on demand, so there may be timing involved as well.

Anyone experience this issue and/or know how to resolve?


Hello there,
Thanks for visiting us,this is technical support and we are truly sorry for the trouble.
Firstly,could you double check the Audio Settings in TV and switch to “pass through” mode if it worked in other mode,then check does this issues still persist or not.
We also will discuss with engineer team for this issues.
Many thanks.

Best Regards,

Hi Kevin -

Thanks for reaching out. I set the TV to pass through mode (was Auto). Worked most of the day, then stopped working a moment ago.

This time the issue happened when I switched between two channels on an AppleTV’s DirectTV Stream app (playing through HDMI1 to Samsung TV, which then sends eARC out over HDMI3 to the receiver).

I just switched between the two channels (same content) again after a reboot and issue did not reproduce. Both channels show on my receiver as “Dolby Digital + Dolby Surround”. However, when the sound stopped working it was showing only “Dolby Digital” no matter the content.

I can also confirm that when sound isn’t going back to the receiver over eARC, I can still switch to the receiver’s HDMI input and see that video is carried from the receiver. After cycling the balun, the audio came back immediately.


After discussed with our engineer team and there have some points want to check with you:

  1. This issues happened when change channel on app ONLY ,but not the input channel, right?
  2. Which cble type you used, shieled twisted cat 6/6a/7? How long the cat cable length?
  3. The Audio format keep setup with "Dolby Digital + Dolby Surround“ and it will auto switch to “Dolby Digital” when it stop working, After reboot our extender to make it work back and the audio format also go back to "Dolby Digital + Dolby Surround“, right?
  4. What are those LED indicator lights status on transmitter and receiver of 4KEX40-eARC when it stopworking?
  5. When system not work,are there have any changed on the environment,such as switch the lights, refrigerator, etc.
  6. System work on eARC mode or ARC mode? If is eARC, and please try switch to ARC mode to work fo and testing for a while and check does this issues still persist or not?
  7. What’s more,does it have a little improvement after switched to “pass through”, lower frequency then auto mode?
    Appreciate for you hard work on our products.
    Have a good day~

Best Regards,

Hi Kevin -

Thanks for the fast response.

  1. Yes, i almost never change input channels. This seems to happen just changing apps or changing programs within apps.

  2. Cat6a, ~120ft (per cable tester). Generally high end cables and all pins test out clean with my cable tester. No couplers or other items between the two extenders.

  3. Correct. Not sure this is always the case, but this is what I noticed last time I tried.

  4. Lights indicate eARC connected (first 3 lights solid green) - same as when it is working

  5. No changes to environment at all

  6. Will try this.

  7. No difference. It seems that in auto mode it was passing through anyway (other option is PCM which would only support stereo audio)

No problem on trying things. I’m sure we will find a solution. Thanks!

Appreciate for your clarifying so quickly,we will check and then get back to you asap once there have any update from our team.

With only ARC enabled (and not eARC), I’ve been unable to reproduce the issue.

I will note that switching to ARC after audio hangs in eARC mode does not restart audio.