8KSW12DP-DM, Keyboard input switches to other PC

For the most part the KVM is working well. However seemingly random, I’ll hear the tell-tale “USB unplugged, USB plugged” sound from Windows and the keyboard stops working. If I unplug the keyboard from the KVM and replug it, I still get no keyboard. All other USB ports and the monitors are working OK. If I move the keyboard out of the dedicated keyboard port and into one of the standard USB ports, I can use the keyboard again.

However, it just happened and I now understand what is happening.

When I get the tell-tale sounds of USB unplug/plug, the keyboard port is being moved to the other connected PC. But the monitor and mouse and all other USB ports are still on the correct PC.

I confirmed this by blindly opening an app (windows-key, type name, press enter), after I lost the keyboard. I then pressed the button to switch to the other PC, and sure enough, that app has been opened.

I can fix it by switching to the other PC and back again, but this is clearly a bug in the firmware, or something.

Hi there,

Thanks for getting back to us and we are truly sorry for this issue.
we also have got a similar feedback from another client and also try to reproduce this in our lab,but still cannot make it out.
Could you share with us what is your keyboard model?
And this issues happened at both two PCs side?



I have 2 PCs, lets called them “Work” and “Gaming” PCs. I have so far only noticed this occur with the Work PC. It can occur randomly, but often enough that it will occur 2 or 3 times in any work day. I’ve timed the occurances and there doesn’t seem to be a pattern. It can happen whilst I’m at the PC and when I’m not. For example, it has happened whilst sat back in the chair watching a traning video, so the inputs were idle.

Work PC: Dell Precision 3460, Intel i5 13500, 32GB DDR5, Windows 11
Gaming PC: Asus PRIME X570-PRO, AMD Ryzen 7 5800X, 32GB DDR4, Geforce 3090 Founders, Windows 11
Input: Keychron K8 TKL and Logitech G PRO Wireless
Output: Dell P2723D and Alienware AW3423DWF

I don’t have any other items plugged into the KVM.

Hey there,

we have a new firmware and please try upgrade to check does it help to fis your problem or not.
It is including the new firmware and the upgrade siftware w/ guide manual,need work on the windows computer.
Please you need use the USB-A to micro-usb cable,disable the windows firewall and please running the upgrade software as the administractor access.
Appreciate for your time and waiting for your update.

Best Regards,

Hi, I have this model and have an issue with one of the monitors at a time falling into a state where it needs unplugged in order to register the input. I’ve tested all sorts of cables and direct to the machines & can’t get it to happen without the KVM involved. Can I get a fresh link for the firmware update?

Hello Nick,

Truly sorry for the trouble acused.
Does this issues happen during the switching process?
When this problem happened and the PC can detected the monitor or not?
How about switch back and forth can make it work?
All the cables come in package is DP 1.4a,have you try use other high quality DP 2.0 cable to have a test?
What is the monitor output resolution and refresh rate?
What is your PC model number,graphics card model and monitor model?
Best Regards,

I haven’t tried DP 2.0 cables. The monitors are running 2560x1440 @ 165hz on one machine and @144hz on the other. The part that is most puzzling is it’s only one monitor, usually the same one, but not always, and I’ve tried swapping cables between the 2. Honestly at a bit of loss, it works if I unplug the monitor and plug it back in it pops up with the expected display. It’s almost like it falls asleep and can’t wake up.

I don’t know that I’ve tried setting both to 144hz, but if that was the issue I would expect the same behavior from both monitors.

Hi Nick,
Thanks for quickly response.
Could you try change to use thehigh quality DP 2.0 cables have a test.
And also can setup both two monitors with 144Hz for a test.
appreciate for your time.
Best Regards,